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1 Purpose

This lab document describes how to use the Kinetis 120MHz bare metal example projects. Most of the
included demos are pre-configured to run on either the TWR-K70F120M or TWR-K60F120M board.
These are general purpose demos that could be ported to run on any board that uses a Kinetis
120MHz or 150MHz processor as long as the particular device supports the required features for the
demo.

In cases where demo features are not available on both boards only one project might be included.
For example, the K60 family doesn’t support the graphical LCD controller. So the graphical LCD demo
project is only configured to run on the TWR-K70F120M.

Some demos might require additional tower module components. Each project includes a readme.txt

file in the project directory that includes information on the demo project including configuration
directions that are specific to that particular demo.

2 Directory Structure

The directory structure for the bare metal examples has two main folders—build and src. The build
folder contains all development toolchain specific files. All of the source code files are in the src
directory.

The source tree is broken up as follows:

src\common\ - Common utilities such as printf and stdlib are provided in this directory
src\cpu\ - CPU specific initialization and header files here

src\drivers\ - Drivers for some of the various peripherals are provided here.
src\platforms\ - Each supported platform has a header file that defines board specific
information, such as the input clock frequency used for that board.

e src\projects\ - This directory holds all the individual example project source code

3 Toolchain Support

Currently the IAR 6.21.4 and CW10.1 toolchains are supported.

3.1 IAR Embedded Workbench

IAR workspace, project, linker, and support files are provided in kinetis-sc\build\iar. Each example has
its own directory and within that directory is a workspace file (.eww) that will load the supported
projects (usually one project for each supported hardware platform). Each project contains several
configuration options that can be selected using a drop menu. The configuration support different link
targets for different Kinetis memory configurations (e.g. RAM_128KB or FLASH_512KB_PFLASH).
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3.2 CodeWarrior 10.2

CodeWarrior 10.2 project files can be found in the kinetis-sc\build\cw folder. Again, each example has
its own directory.

4 Examples

There are many example projects that highlight the operation of different modules. The "hello_world"
demo is the simplest example, and this project is the baseline used for developing other examples. The
hello_world project will perform basic initialization for the board and then display the device
configuration information on the terminal (default baud rate is 115200).

Each example includes a readme.txt file in the workspace or project directory that gives a description
of what the project does and describes any configuration needed to use it.

Many of the examples are reused from the previous Kinetis sample code release in support of the

100MHz processors. The Drylce, LCDC, and NFC examples are new examples for features that are
introduced for the first time on the Kinetis 120MHz and 150MHz processors.

5 Update OSJTAG

The TWR-K70F120M and TWR-K60F120M both include the OSJTAG circuit. By default all of the demo
projects are setup to use OSITAG to download and debug code. The OSITAG circuit is also used as the
primary serial communication port.

Open Source JTAG (also known as OSBDM on ColdFire tower boards) allows a user to program, debug,
and get serial data from Kinetis devices via a USB cable. The firmware runs on a Freescale
MCFS08JM60 on the underside of the Kinetis tower board. To ensure compatibility between the
drivers, firmware, and terminal window, the latest versions of each need to be installed.

First download and install both of the latest P&E Firmware Updates and Recovery and OSBDM Virtual
Serial Toolkit programs which can be found at http://www.pemicro.com/osbdm

Make sure your tower board is plugged in, and run the P&E Firmware Updater Utility to use the
OSJTAG boot loader to upgrade to the latest OSITAG version.

Under “Select Hardware Type” make sure OSBDM/OSITAG is selected. It should automatically detect
your board settings and fill out the rest of the fields automatically.
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® pMultilink/Osbdm Firmware Update and Architecture Selection Utility - Version 1.04 g@

| | Mew verzsions of PAE's software products autamatically update the firmware of the different hardware
=1 | interfaces az neceszany. This application allows updating/configuration of the hardware for uze with

older applications which do not hawve thiz capability. [Clopyright 2017, PEE Microcomputer Spztems,

Inc.

IEE@I?@ hikbc A A, DEMICI. com

1. Select Hardware Type : [05BDM/05JTAG - Embedded debuq circuitry in Freescale Tower huards?ﬂ

Freezcale embeds an open source debug processor in mary of it's Tower cardz and
Demanstration boards. PEE hasz taken a leading rale, along with the apen source
community, in maintaining and updating the firrmaare of thiz hardware. This otilite allows
updating of the firrmware of these boards.

The Multilink Urniverzal iz a much higher speed, more fully featured, interface designed to
wark, either with the tower cards or the uger's own target hardware.

Infarmatian : Chck thiz ink for maore information on this hardware

2. Select Device - |Embedded Kinetic OSBDM/05JTAG Device [Firmware Yersion 30.7] ﬂ

Fefresh list of devices |

3. Select Architecture to Support : |Kinetis j

4_ Firmware File Selection :

("  Automatic
ozbdmenz_arm_3007
" Chooze Firmware Update File or S-Record Select

Unzelected

|Ipdate Firrware

Click on “Update Firmware” to update the firmware. It will prompt you to disconnect the USB cord
from your computer, and then short the JM60 boot loader jumper header. It is J10 and is labelled
JM60 Boot on the silk screen. Then re-connect the board to your computer.

The firmware will then be updated on your board. When it is finished, it will prompt you again to
disconnect the USB cable, remove the jumper, and then re-connect the board again. OSITAG is now
updated.

6 Configure Hardware

The hello world example can be run using either a TWR-K70F120M or TWR-K60F120M stand-alone. No
other tower boards/components are required for this example.
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1) Note that the default jumper settings are in the Quick Start Guide for the TWR-K70F120M and
TWR-SER if you want to change back to the default settings after you are done running the
demo.

2) Connect a mini-B USB cable between the TWR board and the USB port on your computer.

3) Allow the PC to automatically configure the OSJTAG drivers used for debugging and the serial-
to-USB feature. If you have trouble connecting to the board or using the Serial Terminal, see
Section 9 for troubleshooting and make sure you completed the steps listed in Section 3.

7 Launch the Terminal

1) Open the P&E Terminal Utility by clicking on Start Menu->Programs->P&E Kinetis Tower Toolkit-

>Utilities->Terminal Utility
2) Make sure USB COM is selected with 115200 baud, and click on the “Open Serial Port” button.
If you have trouble connecting, see Section 9 for Troubleshooting.

A Terminal Window application v2.01

Fort: |L|5E= COM -
=f=TI[s N 115200
Open Serial Port

Farity [N .

micro

Terminal ¥Window: Clear Window

8 Development Software and Programming the Board

The following instructions describe how to build and flash the hello world demo using CodeWarrior
MCU 10.2 or IAR 6.21.4.

8.1 CodeWarrior for Microcontrollers 10.2

1) Follow the directions in Section 3 to update the OSJTAG firmware and drivers. See Section 9 for
OSJTAG Troubleshooting.

2) Install CodeWarrior for Microcontrollers 10.2.

3) Open CW10. At the welcome screen, set the workspace to the "kinetis-sc" folder location.
These projects use workspace relative paths, so in order for the project to find all files correctly
the workspace must be set to the kinetis-sc folder (the one that contains the build and src
directories).

4) If you already have CW10 open, you can change the workspace by going to File->Switch
Workspace

5) The first time you open CW10, you will be taken to the Welcome screen. Click on “Go To
Workbench” in the lower left hand side.

6) The workbench view will open up. To ensure all the windows are properly set, go to Window->
Reset Perspective
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b Window  Help

Mew Window
| ©Open Perspective k
Shiow Wigw »

Cuskomize Perspective. .,
Save Perspective As...
Resek Perspective, .,

Cloce Dercoarbivg

7) Click on File->Import in the menu bar. In the dialog box that comes up, select “Existing Projects

into Workspace” under the General folder. Then click Next
Select an import source:

bvpe Filker bext

=l [= General
@‘ Archive File
171 Existing Projects inta Workspace
[, File System
L Preferences
H = CfC+H+

8) On the next screen, select the “Select root directory:” option, and click on Browse
9) Navigate to the ..\kinetis-sc\build\cw\hello_world directory and hit OK.
10) Select one or both of the projects to import. Then select Finish.
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Import Projects
Select a directory to search For existing Eclipse projects., ; ;

(%) Select root directory: | D\ Profilesira8956) Deskiopi kinetis-ach buildycw | | Browse. ., |

() select archive file: | |

Projects:
P

I]-hellu:u-wu:urld (D\Profilesirag9s6) Deskiopikinetis-soi buildyowt he Select Al

F0-hello-vorld (D YProfilestragosa) Deskiopi kinetis-scbuildiowi he
Deselect all

flk

Refresh

4 b

|:| Copy projects inko workspace
Working sets

[]add project b working sets

@:‘ Finish ] [ Cancel

11) Select the link configuration that you would like to build. NOTE: the DDR2 configuration is only
available on the K70 project because the TWR-K60F120M doesn’t include DDR memory.

|E|] Includes v MEFOFNIMO_IMTERMAL_RAM

(= MEFOFMIMO_TE MEZOFMIMO_IMTERMAL_FLASH

(= MK FOFM1MO_TH MEZOFMIMO_EXTERMAL_DDRZ
[= Project_Settings
[+ Referenced Proiects

12) Build the project by clicking on the Hammer icon in the toolbar S

13) Click Run->Debug Configurations... in the menu bar, and select the debug configuration
appropriate for the project, build configuration, and hardware connection you are using. For
example, if you are building the k70_hello_world project to run from the internal RAM and
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using OSJTAG as your debugger, then you would select the k70-hello-
world_MK70FN1MO_INTERNAL_RAM_OSITAG configuration. Then hit the debug button in the
bottom of the window

* Debug Configurations

Create, manage, and run configurations

Download an application ko a target, then debug or run the application,

E Codewtarrior Attach
E Code'Warrior Connect
= E CodetWarrior Download

k70-hello-world_MK70FM1MO_EXTERMAL_DDR_OSITAG
k7 0-hella-warld_MKZOFM1MO_EXTERMAL_DOR_PrE L-MultiLink
k70-hello-world_MK70FM1IMO_EXTERMAL_DDR_Segger J-Link_Trace
k70-hello-world_MKZOFMIMO_INTERNAL_FLASH_OSITAG
k70-hello-warld_MK7OFMIMO_IMTERMAL_FLASH_PrE U-MultiLink
k7 0-hello-world_MK7OFN1MO_INTERMAL_FLASH_Segger J-Link_Trace
|70-hello-world_MKZOFMIMO_INTERMAL_RAN TAG
k70-hello-world_MKZOFM1M0_TMTERMAL_RAM_PAE L-MulbiLink
k70-hello-world_MKTOFM1MO_INTERMAL_RAM_Segger J-Link_Trace

I Launch Group

< >
Filter matched 13 of 13 items

@

Py

Name: | k70-hello-world_MK7OFNIMO_INTERMAL_RAM_OSITAG

=] Main
CiC++ application

k70-hello-warld

(0= Arguments | % Debugger & Source | B Environment | =] Common ﬁ“ Trace and Profile

Erowse,.,

[Search Prujact.‘.] [ Browse. ., ] [ ‘ariables. .. ]

Projeck:

Application; | MEFOFM1MO_INTERMAL_RAM/kFO-hello-world.af x

Build (if required) befare launching
Build configuration: |ME7FOFM1MO_INTERNAL_RAM v

(O) Disable auto build
Confiqure Workspace Settings. ..

(C)Enable auto build
@Use workspace settings

Remote system

V] T

Connection: | -4 k70_hello_world_MK7OFM1MO_INTERMAL_RAM_OSITAG Hew. ..

14) If this is the first time you’ve used CW10.2 with your board, you may get a dialog box asking to
update the OSJTAG firmware. Unplug your board, put a jumper on J10 which is labeled JM60
Boot, and plug the board back in. Hit “OK” on the dialog box, and the board OSJTAG firmware
will update. When it is done, unplug the board, remove the jumper on J10, and hit “OK” again
on the dialog box. If you do not have a spare jumper, you can temporarily use the one on J9.

15) The code will then be downloaded to the board and the debugger started. This may take a
several moments. You may also see the following Warning message:

CodeWarrior Alert

Secure Warning

%

‘Cancel aborts the operation as well,

I Yes Mo

J |

| [ concel ]

The current download operation attempts ko modify the Flash Control Field (FCF). Therefore, the target processor may become secured irreversibly,
This is often caused by an incorrect Linker Command File that does not reserve the FCF address range From 0400 bo Dx40F, Do you wank to abork?
Choose "fes' ko abort, avoiding an urwwanted secure of the target ar 'No' ko continue downloading (OMLY IF you really intend to modify the FCF).

This is a check introduced with a CodeWarrior compiler patch. Hit No to continue flashing the
part, as the sample code is configured to ensure the part remains unsecured.
16) Once the code is done flashing, the code will pause at the start of the main() function.

17) Hit the run icon to continue the program execution. ¥
18) On the terminal you should see the hello world message.
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8.2 IAR Embedded Workbench for ARM 6.21.4

1) Follow the directions in Section 3 to update the OSJTAG firmware and drivers. See Section 9 for
OSJTAG Troubleshooting.

2) Install IAR for ARM v6.21.4 or higher.
3) Open the workspace at ..\kinetis-sc\build\iar\hello_world\hello_world.eww

4) Select the project for the board you are using either hello_world_k70_tower or
hello_world_k60_tower

Overview || helln_wurld_k?‘lj_tnwerj[hellcu_wu:urld_kEEl_tu:uwer ”

5) Select the link configuration that you want to build. NOTE: the DDR2 configuration is only
available on the K70 project because the TWR-K60F120M doesn’t include DDR memory.

./: IAR Embedded Workbench IDE

File Edit Wew Project Tools Window Help

D

Wiorks pace

RaM_128KE w

FLASH_1M
FFLASH_512KB_DFLASH_512KE
CDR2_123ME

R

6) Compile the project by clicking the Make icon
“Make”).

7) After compilation completes, download the code to the board and start the debugger by

(or right clicking on the project and select

pressing the “Download and Debug” button &

8) The code will download, and the debugger screen will come up and pause at the first
instruction. Hit the “Go” button to start running.

= R I RIS § G
P Pl 7 v e [V
A o

* cortex_k
Ii 1

19) On the terminal you should see the hello world message.

9 C(Creating New Projects

The kinetis-sc\build\iar\make_new_project.exe or kinetis-sc\build\cw\make_new_cw_project.exe files
can be used to clone the hello_world project for the appropriate toolchain. The script will prompt you
for a name to use for the new project, and then create copies of all needed files and folders.
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10 OSJTAG

Open Source JTAG (also known as OSBDM on ColdFire tower boards) allows a user to program, debug,
and get serial data from Kinetis devices via a USB cable. The firmware runs on a Freescale
MCFS08JM60 on the underside of the Kinetis tower board.

The latest firmware and drivers can be found at http://pemicro.com/osbdm. See Section 3 or the
Installation and Operation document on the P&E website for details on updating the firmware and
drivers. If you are having trouble connecting, try updating to the latest drivers, virtual serial toolkit,
and firmware located on that website.

When the tower board is plugged in, it should enumerate as a composite device, with one driver for
debugging, and the other as a serial port. If you go to the Device Manager you should see the
following:

+ ; CWDYCD-ROM drives
+|-idg Human Interface Devices
+-i= IDE ATA/ATAPT controllars
--E& Jungo
(B8 PEMicra USE Serial Part (i1} )
E& UsE mMulkilink, 2.0
E& WinDriver
+- Keyboards
- & LibUSB-Win32 Devices
i Open Source BOM - Debug Port )
+-- [} Mice and other pointing devices
+ L Modems
+- 8 Manitors

If you only see it enumerate as the Open Source BDM Debug Port, then your computer may
automatically picking up an outdated driver. To fix this, right click on the OSBDM driver and select
“Uninstall”. Then unplug and re-plug in the board, and it should enumerate correctly.

T

-6 LibUSB-Win32 Devices
E%P Cpen Saurce BOM - Debug Par

IUpdate Driver...
+- ) Mice and other pointing devices P

+ L Maodems Dls.al:ule
+- & Moritars Uninstall
—|- H8 Metwork adapters Sran Fov bardiare channes

If there are still problems with enumerating correctly, you can also manually select the drivers.
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Found New Hardware Wizard

Welcome to the Found New
Hardware Wizard

Thiz wizard helpz you install software for;

Open Source BOM - Debug Part

{ } If your hardware came with an installation CD

*-:4;.‘;'3 or floppy dizk, inzert it now.

What do you want the wizard ba da?

() Install the software automatically [Recommended)
< (vyinstall from a list or specific location [Advancedf

Click Mest ta continue.

‘. Cancel
Found New Hardware Wizard

Please choose your zearch and installation options.

() Search for the best driver in these locations.

Ize the check bores below ta limit ar expand the default search, which includes local
pathz and removable media. The best diver found will be ingtalled.

{:@@:ﬂt gearch. | will chooze the driver tl:uiﬂsi_all.z::)

Choose this option to zelect the device driver from a list. *Windows does not guarantee that
the driver you chooze will be the best match for your hardware,

< Back Mest = Cancel
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Found Mew Har dware Wizard

Select the device driver you want to install for thiz hardware.

Select the manufacturer and model of your hardware device and then click Mest. IF you
G%b have a dizk that containg the driver you want boinstall, click Hawve Disk.

[#]:5how compatible hardware

todel
Open Source BOM - Debug Port

— ]

& This driver iz not digitally signed! )

Tell e why diver signing iz imporkant

[ < Back ” MHewt > l[ Cancel ]

Install From, Disk f'5_<|

Inzert the manufacturer's installation dizk, and then
L, make zure that the correct dive iz selected below.

LCopy manufacturer's files from:

]

|m Q [ Browese... ] )

S ——

e For the Open Source BDM — Debug Port, use the driver at:
C:\pemicro\kinetis_tower_toolkit\Drivers\osbdm\OSJTAG_Debug_Interface_libusb.inf

e Forthe PEMicro USB Serial Port (i1), use the driver at:
C:\pemicro\kinetis_tower_toolkit\Drivers\osbdm\OSJTAG_Serial_Interface_windriver_version.inf
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